Most Valuable Professional


View Jan Karel Pieterse's profile on LinkedIn subscribe to rss feed
Subscribe in a reader

Subscribe to our mailing list

* indicates required

Audit !!!

Probeer onze RefTreeAnalyser
de beste Excel formule auditing tool.

Cursussen

Excel VBA Masterclass (Engels)
Excel VBA voor Financials

Third party tools

Speed up your file

FastExcel
The best tool to optimise your Excel model!

Repair your file

Stellar Phoenix Excel Repair
Best tool to repair corrupt Excel sheets and objects
Home > Nederlandse site > Artikelen > Excel Namen > Formule in naam
This page in English

Bereiknamen in Excel

Een stap verder: een formule in een gedefinieerde naam

Tot nu toe verwezen de namen in dit artikel steeds naar een bereik cellen. In werkelijkheid is een naam eigenlijk aan een formule gekoppeld. In het geval van een celbereik in de eenvoudige vorm van bijvoorbeeld =Blad1!$B$2:$B$4.

Maar in deze formule mag elke willekeurige functie van Excel worden toegepast. Ofwel: iedere functie die in een cel mogelijk is, kan ook in een naam gebruikt worden. Dit opent een wereld van mogelijkheden!

Bekijk Afbeelding 12. Hierop wordt (met cel B5 als actieve cel) de naam Kolomsom gedefinieerd. Hierbij wordt ook het principe van een relatieve verwijzing toegepast zoals al eerder besproken is. De formule in Kolomsom is:

=SOM(B$2:B$4)

Ofwel de som van de drie cellen van rij 2 tot en met 4 in dezelfde kolom.


Afbeelding 12: Formule in naam

Door vervolgens in de cellen B5 tot en met D5 deze formule in te voeren: =KolomSom (zie Afbeelding 13), kan door middel van de formule in de naam KolomSom de som van de drie bovenliggende rijen worden bepaald. Het voordeel van een dergelijke werkwijze openbaart zich vooral bij complexe formules: bij een wijziging hoeft alleen de formule in de naam aangepast te worden en niet in vele cellen.


Afbeelding 13: Formule in cellen

Een andere handige eigenschap van bereiknamen is dat ze zich standaard gedragen als matrix formules.